Bug report #5327

Nodetool partially broken on qgis-master

Added by Alexander Novoselov over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15028

Description

in this video, strange behavior nodetool: http://youtu.be/Z4cUn3-xx6E

QGIS version 1.9.90-Alpha
QGIS code revision exported
Compiled against Qt 4.6.2
Running against Qt 4.6.2
GDAL/OGR Version 1.6.3
GEOS Version 3.1.0
PostgreSQL Client Version 8.4.3
SpatiaLite Version 2.4.0
QWT Version 5.2.0

Ubuntu 10.04

testcase.zip (5.69 KB) Alexander Novoselov, 2012-05-30 01:24 AM


Related issues

Duplicates QGIS Application - Bug report #5259: moving polygon individual nodes broken in qgis master, en... Closed 2012-03-29

Associated revisions

Revision b870b556
Added by Jürgen Fischer over 7 years ago

node tool fixes:
- fix OTFR support (fixes #5327.16)
- smaller snap tolerance for geographic CRSs (fixes #5661)
- use different snapping epsilons in QgsVectorLayer::snapToGeometry() for
layers with geographic and projected crs.
- [API] enhancements (to fix #5661): * QgsGeometry::closestSegmentWithContext: allow passing of segment snapping
epsilon * QgsPoint::sqrDistToSegment: allow assing of segment snapping epsilon * QgsMapLayer::crs() add "const"

History

#1 Updated by Filipe Dias over 7 years ago

This also happens on Windows 7, current Master.

#2 Updated by Salvatore Larosa over 7 years ago

  • Priority changed from Normal to High

Also I can confirm the issue to polygon feature!

QGIS version 1.9.90-Alpha
QGIS code revision 95045f8
Compiled against Qt 4.7.4
Running against Qt 4.7.4
GDAL/OGR Version 1.9.0
GEOS Version 3.3.3
PostgreSQL Client Version 9.1.3
SpatiaLite Version 2.4.0
QWT Version 5.2.2

#3 Updated by James Stott over 7 years ago

I can confirm too using windows 7 master.

I have also noticed that if you select several nodes at once and try to delete them in one go, it will not delete all of them, only one of them. You have to delete them one by one.

#4 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from Nodetool strange work to Nodetool partially broken on qgis-master
  • Category set to Digitising
  • Target version set to Version 1.8.0

#5 Updated by Jürgen Fischer over 7 years ago

  • Assignee set to Jürgen Fischer

#6 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from High to Severe/Regression

#7 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Closed

duplicate of #5327

#8 Updated by Giovanni Manghi over 7 years ago

see also #5259

#9 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Closed to Reopened

#10 Updated by Nathan Woodrow over 7 years ago

This is a still a problem in master and is a major bug as it affects how the node tool behaves, and not in a good way.

Would be good to have this fixed before 1.8 release as hurts the editing features of QGIS pretty bad.

#11 Updated by Giovanni Manghi over 7 years ago

Nathan Woodrow wrote:

This is a still a problem in master and is a major bug as it affects how the node tool behaves, and not in a good way.

Would be good to have this fixed before 1.8 release as hurts the editing features of QGIS pretty bad.

Hi Nathan, this ticket is tagged as blocker for the reason you describe. Is a regression since 1.7.4 and the devs agreed (in Lyson) that new releases won't be shipped with known, hurting regressions.

#12 Updated by Giuseppe Sucameli over 7 years ago

I suppose the geometry is not updated after the vertex is moved and the following steps seem to trust me:

1. move a vertex from position X to Y,
2. move the cursor on to the old vertex position (X)
3. press the mouse button and holding it move the mouse, the vertex is moved.

#13 Updated by Jürgen Fischer over 7 years ago

Giuseppe Sucameli wrote:

I suppose the geometry is not updated after the vertex is moved and the following steps seem to trust me:

1. move a vertex from position X to Y,
2. move the cursor on to the old vertex position (X)
3. press the mouse button and holding it move the mouse, the vertex is moved.

Right. I also noticed. Already fixed that, but there's still more...

#14 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Reopened to In Progress

#15 Updated by Jürgen Fischer over 7 years ago

  • Status changed from In Progress to Closed

#16 Updated by Alexander Novoselov over 7 years ago

qgis 1.9.90+git20120528+5e45e87~precise1

http://youtu.be/HmtyaJmif-k

#17 Updated by Giovanni Manghi over 7 years ago

Alexander Novoselov wrote:

qgis 1.9.90+git20120528+5e45e87~precise1

http://youtu.be/HmtyaJmif-k

can you share the shape you used in this screencast? This would allow us to see if after the latest changes it still work like in the video.

#18 Updated by Alexander Novoselov over 7 years ago

wait for nightly build to test

#19 Updated by Alexander Novoselov over 7 years ago

http://youtu.be/CUVE36xzLmY

the first change does not work and slow work when reverting

Layer = PostgreSQL database with PostGIS extension

#20 Updated by Alexander Novoselov over 7 years ago

the same thing on a shp

#21 Updated by Giovanni Manghi over 7 years ago

Alexander Novoselov wrote:

the same thing on a shp

Hi,

I just updated on Ubuntu and tested on fairly large postgis dataset (215000 records) and It seems pretty quick to me. It seems also to works correctly now. What revision are you using?

Reverting changes when hitting "discard" is slow as it was before, but that is another issue.

#22 Updated by Alexander Novoselov over 7 years ago

1.9.90+git20120529+56d0387~precise1

The main problems are solved, not only introduced the first change in the line (on video).

Cancel changes to the previous version was not so long, it has emerged recently.

Sorry for the English - Google Translator

#23 Updated by Jürgen Fischer over 7 years ago

Giovanni Manghi wrote:

Reverting changes when hitting "discard" is slow as it was before, but that is another issue.

and I suppose the background layers used in the video make it stand out, that the canvas is refreshed with each "undo". Anyway, that's not a problem of the nodetool at all.

#24 Updated by Alexander Novoselov over 7 years ago

Yes, but in my example of two shapefiles (see above), is slow work, too. Create a new ticket?

#25 Updated by Giovanni Manghi over 7 years ago

Alexander Novoselov wrote:

Yes, but in my example of two shapefiles (see above), is slow work, too. Create a new ticket?

can you attach a sample of your data, enough to replicate the issue?

#26 Updated by Alexander Novoselov over 7 years ago

Giovanni Manghi wrote:

can you attach a sample of your data, enough to replicate the issue?

This problem (not done the first move the node) is observed only in ubuntu 10.04. In Ubuntu 12.04 no problem.
Probably this is not an big issue.

Also available in: Atom PDF