Bug report #5226

Unable to select multiple features in new symbology

Added by Kenton Ngo over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:1.7.4 Regression?:No
Operating System:Mac OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:14962

Description

Using old symbology, holding down the Apple key I can select multiple features and apply the same line or fill styles to them. However, under new symbology I can only change them one at a time, which is rather inconvenient. This ought to be fixed before Old Symbology is dropped.

This would be useful for categorized maps, where I'd like to highlight let's say 4 out of 50 states. Under Old Symbology I can select all four and apply a symbol (five or seven clicks), but if I had do them one at a time it would be very annoying. While one can work around this problem by, say, creating a database column or creating special rules in Rule-based symbology, I still like the convenience of just being able to click four times.

History

#1 Updated by Nathan Woodrow over 8 years ago

Can you try a nightly build as this has already been added.

#2 Updated by Giovanni Manghi over 8 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Nathan Woodrow wrote:

Can you try a nightly build as this has already been added.

This thicket is duplicate of #3275.

Yes, in master you can select multiple classes and change in one go a number of options, but not the symbol as in the old symbology. A really needed feature.

Also available in: Atom PDF