Bug report #5155

memory layer attribute fields are combined when a memory layer or columns in a memory layer are deleted

Added by Alister Hood over 8 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:14907

Description

I guess this is a problem with the "Memory layer" data provider, but I could be wrong.

1) When I use the "Profile from Line" plugin it creates a memory layer called "temporary points". If I then run the plugin again (possibly selecting a different raster to sample), it creates another memory layer called "temporary points". Everything is fine at this stage, however if I delete one of the layers and then open the attribute table of the other layer, it looks like attribute tables of the two layers have been combined (there are twice as many columns).

2) Similarly, if I use the "delete column" tool on a memory layer, when I reopen the attribute table it has combined the old set of columns with the new set of columns, so all of the columns except the ones I deleted appear twice!

History

#1 Updated by Regis Haubourg almost 8 years ago

I tried to reproduce with new memory layers from "new memory layer plugin" and I could not reproduce. Could this be a Profile From Line plugin bug?

#2 Updated by Alister Hood almost 8 years ago

  • Operating System set to All

I tried to reproduce with new memory layers from "new memory layer plugin" and I could not reproduce

Ah, yes. I don't seem to be able to reproduce either issue with layers from the "new memory layer" plugin either.

Could this be a Profile From Line plugin bug?

Maybe; I can't say I understand anything about how all this works.
If that is the case it would seem strange to me though. I would have thought if you create a memory layer you create a memory layer. What could the "Profile From Line" plugin be doing wrong? What does it do differently from the "New Memory Layer" plugin?

#3 Updated by Regis Haubourg almost 8 years ago

Maybe it does not identify correctly layers (not using id but name for example.. )

#4 Updated by Alister Hood almost 8 years ago

But the issues occur when using built-in features of QGIS, not when using the plugin.

#5 Updated by Paolo Cavallini almost 8 years ago

  • Target version set to Version 2.0.0

#6 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Médéric RIBREUX over 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

I think we can close this bug. The new memory layer has been implemented in QGIS core (the old memory layer has been dropped, as far as I know).
Do you still have problems with the Profile plugin ?

#8 Updated by Alister Hood over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Yes, I can't find a recent copy of the profile from line plugin so I guess we'd better close it because we can't test anymore.

Also available in: Atom PDF