Bug report #5118

Floating controls in the print composer do not close (and continue to operate) when you close the composer

Added by Alister Hood over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Nathan Woodrow
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14877

Description

In the print composer in master, I have detached the the "Item properties" and "composition" panes, so they are now floating. When I close the print composer they remain open, and if I make changes in them, when I reopen the print layout the changes have been applied. Funky ;)

Associated revisions

Revision 479907f9
Added by Nathan Woodrow over 10 years ago

Disable floating dock widgets in composer. Fix #5118

History

#1 Updated by Nathan Woodrow over 10 years ago

This seems to be a bug with Qt and having more then one QMainWindow with dock widgets. I did find a bug report one day but can't seem to find it now.

I was thinking that maybe to disable floating dock widgets in the composer for now until a better fix can be found. Random floating dock widgets would be confusing to users.

#2 Updated by Nathan Woodrow over 10 years ago

  • Assignee set to Nathan Woodrow

#3 Updated by Nathan Woodrow over 10 years ago

  • Status changed from Open to Closed

#4 Updated by Nathan Woodrow over 10 years ago

Ok I have disabled the floating dock widgets for now. Doesn't give a good user experience with having a floating dock widget that doesn't close when the parent window does.

Also available in: Atom PDF