Bug report #5096

Always use the same dialog for opening/saving files

Added by Paolo Cavallini over 8 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:14859

Description

Some dialogs for opening or saving files is custom, some other is OS standard. Better replace them all with OS standard


Related issues

Duplicates QGIS Application - Bug report #3763: The "other" open/save file dialog has timeouts or causes ... Closed

History

#1 Updated by Jürgen Fischer over 8 years ago

See #3763. What's still missing?

#2 Updated by Giuseppe Sucameli over 8 years ago

I think he's talking about plugin's dialogs (I'm right?). GdalTools, SPIT (and maybe other core plugins) use a custom dialog to handle encoding.
I agree that displaying different and ugly dialogs is bad, but is it better than have encoding combobox out of it?

Anyway, in GdalTools I can move the encoding combobox out of the file dialog (like Add Vector Layer dialog).
The same could be done in SPIT moving the encoding to a new column (after the filename one).

I don't remember where the custom dialog with the "Cancel All" button is used so I cannot propose any valid alternative for it.

#3 Updated by Paolo Cavallini over 8 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #3763

#4 Updated by Paolo Cavallini over 8 years ago

  • Resolution deleted (duplicate)
  • Status changed from Closed to In Progress

#5 Updated by Alister Hood over 8 years ago

I agree that displaying different and ugly dialogs is bad

On Windows perhaps a bigger issue is that the QT dialog "takes forever and a half (approximately) before it shows the files in the directory" (quote from #3763)

(and maybe other core plugins)

Yes, ftools.

#6 Updated by Paolo Cavallini about 8 years ago

  • Target version set to Version 2.0.0

#7 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#8 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#9 Updated by Paolo Cavallini over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from In Progress to Closed

Seems solved now, in QGIS 3

Also available in: Atom PDF