Bug report #4867

drag and drop fails

Added by Giovanni Manghi over 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14695

Description

When dragging and dropping the attached shape from the qgis browser to a SL connection in DB manager I get

Feature write errors:
Creation error for features from #0 to #199
Creation error for features from #200 to #245
Only 0 of 246 features written.

the layer is then available in the SL db but it has no geometries in it.

It happens also with other shapesfiles, but not all.

TM_WORLD_BORDERS-0.3_shp.zip (297 Bytes) Giovanni Manghi, 2012-01-24 05:43 AM

History

#1 Updated by Giovanni Manghi over 8 years ago

I get the same error when dropping into a PG connection.

#2 Updated by Paolo Cavallini over 8 years ago

The attachment seems to have only a .prj file.

#3 Updated by Paolo Cavallini over 8 years ago

  • Priority changed from Normal to High

#4 Updated by Giovanni Manghi over 8 years ago

Paolo Cavallini wrote:

The attachment seems to have only a .prj file.

http://thematicmapping.org/downloads/TM_WORLD_BORDERS-0.3.zip

#5 Updated by Giovanni Manghi almost 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Project changed from 27 to QGIS Application

#6 Updated by Giovanni Manghi almost 8 years ago

  • Category set to DB Manager

#7 Updated by Giovanni Manghi almost 8 years ago

  • Assignee deleted (Giuseppe Sucameli)

#8 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF