Bug report #4850

Labeling engine settings: always defaults values

Added by michele zanolli over 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14684

Description

I noticed that, when reopening Qgis, all the changes previously made inside the labeling "Engine settings" (Search methods, Show all labels,...) are lost. Defaults values are restored.

Is it possible to store these settings inside a project file?

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Tracker changed from Feature request to Bug report
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

Confirmed on master

#2 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#3 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Seems fixed on master.

#5 Updated by Larry Shaffer about 7 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (fixed)

Hi Giovanni,

I reopened this because only the 'show all labels' is currently saved per layer. All the settings for the labeling engine in the noted dialog are still not saved anywhere. Those could be saved/reloaded at the project level, as Michele indicated.

#6 Updated by Anita Graser almost 7 years ago

  • Priority changed from Normal to Severe/Regression

#7 Updated by Larry Shaffer almost 7 years ago

  • Resolution set to fixed
  • Status changed from Reopened to Closed

Hi,

This should be fixed in master with commit bab4395

Also added ability to remove those settings, and a means of restoring defaults.

#8 Updated by michele zanolli almost 7 years ago

Thanks Larry!

Also available in: Atom PDF