Bug report #4676

Python error when interacting with the Clipper raster tool

Added by Giovanni Allegri almost 9 years ago. Updated almost 9 years ago.

Status:Closed
Priority:High
Assignee:Giuseppe Sucameli
Category:GDAL Tools
Affected QGIS version:1.7.3 Regression?:No
Operating System:osgeo4w Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:14566

Description

The following error happens whenever I interact within the Clipper tool (raster/gdal tools):

Traceback (most recent call last):
File "C:/OSGeo4W/apps/qgis/./python/plugins\\GdalTools\\tools\\widgetPluginBase.py", line 28, in someValueChanged
self.emit(SIGNAL"), self.getArguments())
File "C:/OSGeo4W/apps/qgis/./python/plugins\\GdalTools\\tools\\doClipper.py", line 105, in getArguments
return self.getArgsModeMask()
File "C:/OSGeo4W/apps/qgis/./python/plugins\\GdalTools\\tools\\doClipper.py", line 143, in getArgsModeMask
if self.alphaBandCheck.isChecked():
TypeError: 'sip.methoddescriptor' object is not callable

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Affected QGIS version set to 1.7.3
  • Crashes QGIS or corrupts data set to No

This does not happens on QGIS-master/osgeo4w

How do I get this error on 1.7.3:

new project

add a raster

raster -> clipper

mask layer -> go pick a vector -> after clicking "ok" the message pops up

#2 Updated by Paolo Cavallini almost 9 years ago

  • Status changed from Open to Feedback

Please check on master and give further details.

#3 Updated by Giuseppe Sucameli almost 9 years ago

It's due to a python bug, fixed in python v2.5.3 and v2.6.1 (see http://www.riverbankcomputing.com/pipermail/pyqt/2011-February/029218.html).
AFAIK there no way to handle it, except commenting that line...

#4 Updated by Paolo Cavallini almost 9 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

This depends from the Windows packaging (old version of Python). Nothing to do with QGIS.

#5 Updated by Paolo Cavallini almost 9 years ago

Better helping osgeo to upgrade their Python, long overdue.

#6 Updated by Jürgen Fischer almost 9 years ago

Paolo Cavallini wrote:

Better helping osgeo4w to upgrade their Python, long overdue.

See also OSGeo4W #219

Also available in: Atom PDF