Bug report #4622

Labelling expression: toint() produces negative values

Added by Paolo Cavallini almost 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:Nathan Woodrow
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14524

Description

Displaying a numeric fields is ok. Applying toint(the_same_field) produces some incorrectly negative values, in a non obvious pattern.

butta.tar.gz (51.2 KB) Paolo Cavallini, 2012-01-08 12:54 AM


Related issues

Related to QGIS Application - Bug report #3132: Field calculator cannot calculates area of polygon Closed

Associated revisions

History

#1 Updated by Paolo Cavallini almost 8 years ago

  • Category set to Labelling

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#3 Updated by Martin Dobias over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

Unable to reproduce. Please attach some test data and instructions.

#4 Updated by Paolo Cavallini over 7 years ago

The expression is:
toint( $area )
The result is:
-475140599

Sample attached.

#5 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF