Bug report #4581

Simple fill border drawn like it is not "closed"

Added by Alister Hood over 8 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:14488

Description

For a polygon layer using a "Simple fill" style, the outline has bevelled corners, except that the start/end point is drawn as if it was a polyline - the two edges do not meet. See the attached screenshot.

corners.png (1.93 KB) Alister Hood, 2012-01-07 05:05 AM

History

#1 Updated by Alister Hood over 8 years ago

  • File deleted (corners.TIF)

#2 Updated by Alister Hood over 8 years ago

  • File corners.png added

Sorry, screenshot had wrong extension somehow

#3 Updated by Alister Hood over 8 years ago

the two edges do not meet

I mean it draws two lines ending at the start/end point, rather than drawing a bevelled corner.

#4 Updated by Giovanni Manghi over 8 years ago

  • Target version set to Version 1.7.4

#5 Updated by Martin Dobias over 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

I am unable to see the image, it seems broken.

Anyway valid polygons should be made from linear rings, i.e. polylines where the first and last coordinates are the same. This may be the source of the problem in your case, so the outline is not drawn properly.

Probably the only correct thing to do is to fix your data: we have to avoid checking of validity of geometries as it would slow the rendering significantly (there may be other validity problems, some are handled fine by rendering functions, others not).

#6 Updated by Alister Hood over 8 years ago

  • File deleted (corners.png)

#7 Updated by Alister Hood over 8 years ago

Alister Hood wrote:

Sorry, screenshot had wrong extension somehow

Martin Dobias wrote:

I am unable to see the image, it seems broken.

Oh, sorry, it was a tif after all (But I was sure I checked it displayed in my browser...)
# file corners.png
corners.png: TIFF image data, little-endian

Here's a png.

#8 Updated by Alister Hood over 8 years ago

Martin Dobias wrote:

Anyway valid polygons should be made from linear rings, i.e. polylines where the first and last coordinates are the same. This may be the source of the problem in your case, so the outline is not drawn properly.

Probably the only correct thing to do is to fix your data: we have to avoid checking of validity of geometries as it would slow the rendering significantly (there may be other validity problems, some are handled fine by rendering functions, others not).

That isn't the problem here... or at least, if it is, then is all polygons created by the digitising tool are magically invalid :)

#9 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#10 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#11 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#12 Updated by Médéric RIBREUX over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

I am not able to reproduce this with QGIS 2.13 master. You can set the join style for the Simple Fill outline and with whatever option, the rendering is correct.

I am closing this bug.

Also available in: Atom PDF