Bug report #4557

Crash when loading nodes into the QgsProject instance with debug enabled.

Added by Borys Jurgiel almost 8 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data: Copied to github as #:14470

Description

If the project is not saved yet and paths are set to relative and CMAKE_BUILD_TYPE is set to Debug, then calling QgsProject.instance().read(some_node) (at least from Python) causes a crash when testing the non existing project file:

Fatal: ASSERT: "pfi.exists()" in file /home/borys/sources/Quantum-GIS/src/core/qgsproject.cpp, line 1368
Core dumped

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#2 Updated by Alexander Bruy almost 8 years ago

Which QGIS version? This should be fixed in master. Also I just backport this fix to 1.7 and 1.8

#3 Updated by Borys Jurgiel almost 8 years ago

  • Status changed from Open to Closed

Yes, it seems to be fixed now. Thanks!

Also available in: Atom PDF