Bug report #4541

Change interface of SVG symbols list: tree

Added by Paolo Cavallini about 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:14457

Description

The current layout of SVG symbol list (preview of all symbols in a single box) is ok for up to 20-30 symbols. Now that we have more, and should add even more, a clickable tree is more appropriate.
Should be very easy to implement.

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version set to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Paolo Cavallini almost 8 years ago

This has been implemented nicely in Styles. Please add the same solution to other places (namely, the Print composer). The composer should also load faster, and take less space, so it will be a significant improvement.

#5 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Nyall Dawson over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #8257

Also available in: Atom PDF