Bug report #4534

"Split vector layer" freezes QGIS

Added by Giovanni Manghi almost 8 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:14451

Description

It was tested on master and 1.7.1 on both Debian and Ubuntu. On OsX gives an error message but eventually finishes the task. It seems to work under Windows.

May be a python version problem?

Traceback (most recent call last):
  File
"/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/pickle.py",
line 1366, in dumps
  File
"/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/pickle.py",
line 224, in dump
  File
"/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/pickle.py",
line 306, in save
  File
"/System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/copy_reg.py",
line 71, in _reduce_ex
TypeError: the sip.simplewrapper type cannot be instantiated or sub-classed

Versione Python:
2.6.1 (r261:67515, Jun 24 2010, 21:47:49)
[GCC 4.2.1 (Apple Inc. build 5646)]

Related issues

Duplicated by QGIS Application - Bug report #7031: divide (split) polygon doesn't work Closed 2013-01-23

Associated revisions

Revision 98d8d507
Added by Jürgen Fischer over 6 years ago

Merge pull request #378 from slarosa/ftools_split_vector

fix #4534

History

#1 Updated by Alexander Bruy almost 8 years ago

There are no fTools files in traceback, so this is not fTools issue. Maybe something wrong with your Python install?

#2 Updated by Paolo Cavallini almost 8 years ago

Confirmed here on Debian unstable. Tried bot over nfs and on local disk, same problem.
Apparently it is not QGIS being stuck, but rather the dialog remaining open and doing nothing

#3 Updated by Paolo Cavallini almost 8 years ago

  • Priority changed from Normal to High

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#5 Updated by Alexander Bruy over 7 years ago

Seems this error specific for 64-bit systems. I receive two reports about freezes and craches when users tried to press OK button in QFileDialog. In same time same QGIS version works fine under 32-bit OS on same PC. So I think this is not a QGIS/fTools issue but Qt/PyQt one.

#6 Updated by Giovanni Manghi over 7 years ago

Alexander Bruy wrote:

Seems this error specific for 64-bit systems. I receive two reports about freezes and craches when users tried to press OK button in QFileDialog. In same time same QGIS version works fine under 32-bit OS on same PC. So I think this is not a QGIS/fTools issue but Qt/PyQt one.

I confirm that on 32bit OSes it works ok, on 64bit it doesn't.

#7 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data set to Yes
  • Subject changed from "split vector layer" freezes QGIS to "Split vector layer" freezes QGIS on 64bit OSes
  • Priority changed from High to 6
  • Affected QGIS version set to master

#8 Updated by Giovanni Manghi over 7 years ago

  • Priority changed from 6 to High

#9 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

this need to be tested with a more recent GEOS version.

#10 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#11 Updated by Toni Keskitalo about 7 years ago

Hello. This issue happens also on 32bit, at least on my system: Kubuntu Oneiric 11.10, kernel 3.0.0-20-generic-pae, 4GB memory, Qgis 1.8.0 from ubuntugis-unstable. Additionally, after killing qgis.bin all the additional plugin repositories disappear from the list but other settings seem to be intact.

#12 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#13 Updated by Pedro Venâncio almost 7 years ago

Hi,

As to Toni Keskitalo, this is also happening to me in 32bit version (Xubuntu 12.04 with QGIS master from ubuntugis-unstabble).

The tool does not allow me to put the path directly in the 'Output Folder' field, and freezes when I click 'browser' and select the output folder. Then I am forced to force close QGIS, which results in the cleaning of all options and all the customization I did in QGIS (default CRS, plugin repositories, locale settings, wms/wfs/postgis connections, etc.)... Basically, QGIS becomes like in ​​a clean installation.

By the consequences that this error causes in the QGIS installation, it seems to me a matter of high priority.

#14 Updated by Giovanni Manghi almost 7 years ago

  • Subject changed from "Split vector layer" freezes QGIS on 64bit OSes to "Split vector layer" freezes QGIS

#15 Updated by Giovanni Manghi almost 7 years ago

  • Status changed from Feedback to Open

#16 Updated by Giovanni Manghi almost 7 years ago

Definitely happens (now?) also on 32bit.

#17 Updated by Paolo Cavallini almost 7 years ago

Confirmed, still a serious issue

#18 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Works for me now on both Windows and Linux on qgis master. Please reopen if necessary.

#19 Updated by Brian Smith over 6 years ago

  • Status changed from Closed to Reopened

Still broken for me on QGIS 1.70, 1.80, and 1.90 (Master) on Kubuntu 12.10 32-bit.

#20 Updated by Salvatore Larosa over 6 years ago

  • Resolution deleted (fixed)
  • Pull Request or Patch supplied changed from No to Yes

Confirmed, it occurs only under Linux!

This pull should fix the issue: https://github.com/qgis/Quantum-GIS/pull/378

#21 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Reopened to Closed

#22 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF