Bug report #4518

Rotation of labels and symbols should be in the same direction

Added by Paolo Cavallini about 9 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14436

Description

Currently, rotation of labels is counterclockwise, whereas rotation of symbols is clockwise. This gives unexpected results for users, so should be made uniform (either way is good IMHO)

Associated revisions

Revision 21a4ac4d
Added by Nyall Dawson over 3 years ago

Unify label rotation with other rotation settings

Label rotation is now specified in degrees clockwise, just like
symbol rotation, map rotation, etc.

Fix #4518

History

#1 Updated by Martin Dobias about 9 years ago

  • Assignee deleted (Martin Dobias)

#2 Updated by Paolo Cavallini almost 9 years ago

  • Category set to Symbology

#3 Updated by Giovanni Manghi almost 9 years ago

  • Target version set to Version 1.7.4

#4 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#5 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

this is still the case in QGIS 2.13 even with the new label engine...

It's been 4 years since this bug report and perhaps users now expect to have different rotation orientation for labels and symbols ?

Is it still relevant to modify it after all those years without breaking user experience ?

#8 Updated by Paolo Cavallini almost 5 years ago

It is. Planned for 3.0. Thanks.

#9 Updated by Médéric RIBREUX almost 5 years ago

  • Status changed from Feedback to Open

#10 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#11 Updated by Nyall Dawson over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF