Bug report #4504

QGIS fails to print ecw image in composer

Added by Nathan Woodrow almost 8 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:14427

Description

I can't seem to print any ecw raster images.

  • Export to PDF only exports vector layers.
  • Printing to the normal print drivers only prints.
  • Export as Image works as expected with raster shown.

Tried all the settings in the composer and different sizes.

A0.LOG Magnifier (81.7 KB) Nathan Woodrow, 2011-11-08 08:57 PM

A4.LOG Magnifier (27.4 KB) Nathan Woodrow, 2011-11-08 08:57 PM

History

#1 Updated by Nathan Woodrow almost 8 years ago

This seems to be related to memory.

I can print using a A4 and A3 with nothing else running but anything above A3 and QGIS just prints the vectors. Memory usage with ecw at time of print is ~700mb, some of this would be caused by the caching that GDAL does with ECWs.

I tested opening and printing an ecw using uDig (also uses GDAL) and while slow to print still renders correctly.

#2 Updated by Marco Hugentobler almost 8 years ago

Does it work on Linux? If yes, then it might be a 32bit issue. My experience is that large scale printing works with the 64bit versions (windows installer is compiled in 32bit compatibility mode, therefore can only use 2GB memory). I haven't tried ECW though, only geotiff.

#3 Updated by Nathan Woodrow almost 8 years ago

I haven't tested it with Linux yet but I'm not sure it is related to being 32bit. I'm only running 32bit XP and uDig is only a 32bit app and it prints it fine.

#4 Updated by Nathan Woodrow almost 8 years ago

Attached is the log file for both A4 and A0.

Seems that createNextPartImage() and readBlock() are called a lot but most of the values are the same for about three calls each.

#5 Updated by Giovanni Manghi almost 8 years ago

Nathan Woodrow wrote:

This seems to be related to memory.

I have also evidence that such problems (not only with ecws) are related to memory management in Windows, especially XP.

Please give it a try with a Windows Vista/Seven 32/64 bit installation and/or Linux.

If the problem does not surface on Vista/Seven (as I believe), then I would say that we can consider XP obsolete ;)

#6 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#7 Updated by Giovanni Manghi over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Status changed from Open to Feedback

Did you tested on Linux or 64bit Windows?

#8 Updated by Giovanni Manghi over 7 years ago

probably duplicate of #4821

#9 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#10 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#11 Updated by Giovanni Manghi almost 7 years ago

Hi Nathan, any feedback about this issue? Isn't a probable duplicate of #4821?

#12 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from High to Normal

#13 Updated by Jürgen Fischer over 5 years ago

  • Category changed from 33 to Map Composer/Printing

#14 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF