Bug report #4486

Diagrams: export to image or pdf (or direct printing) doesn't respect Print Composer layout when using MM as units

Added by Alban P almost 8 years ago. Updated about 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14412

Description

Hi,

I noticed something wired when I'm using diagrams in QGIS.
In fact, when I'm using diagrams and I use millimeters as unit (no issue with map units) I can't export correctly my map in pdf or png format.

If you look at the first attached image, you can see a map from the print composer with diagrams.
The layout is as I expected but when I'm using an export to pdf or image (even a direct print) I have in output the second image attached.
The position changed and some of them disappeared.

PrintComposer.png - Print Composer layout (604 KB) Alban P, 2011-11-02 09:48 AM

Print.png - Output in png format (1.07 MB) Alban P, 2011-11-02 09:48 AM

History

#1 Updated by alicebtoklas - almost 8 years ago

  • Operating System changed from Windows 7 to All

Same problem for me on ubuntu, only when I use millimeters as unit.
Really annoying.

#2 Updated by Giovanni Manghi almost 8 years ago

  • Subject changed from Export to image doesn't respect Print Composer layout to diagrams: export to image or pdf (or direct printing) doesn't respect Print Composer layout

#3 Updated by Alister Hood almost 8 years ago

export to image or pdf (or direct printing) doesn't respect Print Composer layout

1) I think the problem is actually the other way around:
If you zoom in and out on the print composer, you will notice that the diagrams move around, and different ones are hidden at different zoom levels. So it looks like the diagrams displayed in the composer are being placed by PAL to suit the screen, not the paper. This is similar to #3786 (fixed in Trunk), and I know it also used to be a problem with new generation labels, which also use PAL. (I haven't checked if it is still a problem with labels)
In the composer PAL should place things to suit the paper, which would mean that they would be shown in the same location on the page regardless of the zoom.

2) The placement on the exported page is also quite wrong - maybe it is doing the placement calculations for the wrong scale or something.

#4 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Subject changed from diagrams: export to image or pdf (or direct printing) doesn't respect Print Composer layout to Diagrams: export to image or pdf (or direct printing) doesn't respect Print Composer layout when using MM as units

#5 Updated by Giovanni Manghi over 7 years ago

see also #4345

#6 Updated by Stef Lef over 7 years ago

Still a big problem as of version 1.9 !
1) All exports of diagrams overlay fails when set to MM ... as described by Alister.
2) Priority on the diagram forms dont seem to work if set at a higher priority then low.
3) Tested with all types of rendering and even with old symbology setting.
4) There is no legend for diagrams. Could be cool to include a circle corresponding to the max set in the diagram form.

Version 1.9 Mac

#7 Updated by Matthias Kuhn about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0
  • Status changed from Open to Feedback

Fixed in my repo:

https://github.com/matthias-kuhn/Quantum-GIS/tree/print-diagram

Awaiting approval.

Concerning 4) refer to #4255

edit:
I'm not sure if this is the best way to fix this. The fix feels like messing too much with different units. Maybe there is a simpler fix possible?

#8 Updated by Matthias Kuhn about 7 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Also available in: Atom PDF