Bug report #4433

Edit vertex tool very slow

Added by Marica Landini bulma about 8 years ago. Updated almost 8 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:14365

Description

Dear developers,
we noticed that the tool for the vertex edit since the version 1.5 is very slow.
When we try to edit features (polygons in our case) having a big number of vertices, during an editing session, just clicking with the node tool on a vertex (node) of a selected polygon we have to wait a lot of seconds (proportionally to the number of vertices) before to see the vertices selected in red square.
In the 1.4 version this operation was immediate.
After these selection of vertices the use of the tool (moving a vertex) it is also very slow.
We loaded on http://geo.regione.emilia-romagna.it/gstatico/documenti/qgis/test_node_edit_qgis.zip an example shapefile that we used for these tests.
You can try with the Ferrara Province polygon, although we tried also with others shapefiles and differents polygons.
OS: Win XP, Ubuntu 10.10
qGis versions: since 1.5, till 1.7.1 (with the 1.4 there is no problem)


Related issues

Duplicates QGIS Application - Bug report #4523: QGIS hangs when selecting a feature with the "Node Tool" Closed 2011-11-13

History

#1 Updated by Paolo Cavallini about 8 years ago

Also on Debian, and Windows 7 and Vista, apparently

#2 Updated by Giovanni Manghi about 8 years ago

  • Category set to Digitising
  • Priority changed from Normal to High
  • Target version set to Version 1.8.0

This is easily confirmed and the reason seems to be something related to the (pseudo)topological editing features. Interesting enough QGIS still very slow (basically unusable) when editing large/complex geometries even if the topological editing parameters are not enabled.

#3 Updated by Ben Madin almost 8 years ago

Paolo Cavallini wrote:

Also on Debian, and Windows 7 and Vista, apparently

Also on Mac OS X 10.6 using QGIS 1.7.3 (from William Kyngesbury)

#4 Updated by Ben Madin almost 8 years ago

Sorry, I hit submit instead of preview, but I wanted to add that "(basically unusable)" is most definitely an understatement - but to put some sense of perspective on it, it seems that at about 27000 points in the geometry you can just manage, but a bigger multipolygon (I seem to be dealing with places like the Philippines and Chile a lot at the moment!) often have hundreds of thousands of points, and the whole programme ends up using 1 GB of RAM, 100% of CPU and 10 minutes later hasn't progressed.

I can remember editing these for a project some years ago, so I was just wondering if there is any way to roll back the pseudo-topological editing features for now (they are good, but I need to get rid of some errors).

cheers

Ben

#5 Updated by Paolo Cavallini almost 8 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

Seems fixed now - please test on master.

#6 Updated by Giovanni Manghi almost 8 years ago

  • Status changed from Open to Feedback

#7 Updated by Giovanni Manghi almost 8 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

This is issue is (thanks to Jurgen work) gone, and actually the performances when editing geometries with a lot of nodes (tens of thousands nodes) is now even more efficient of any other GIS software I had testes, both OS and proprietary.

Also available in: Atom PDF