Bug report #4368

Union tool creates shapefile with missing polygons

Added by Andrew Joseph about 9 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/QGIS
Affected QGIS version: Regression?:
Operating System:Windows Easy fix?:
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:14301

Description

When unioning shapefiles in QGIS, the process gets to about 6% and finishes, leaving a layer that is unioned correctly but has missing polygons. I have tested this with multiple files and it fails each time, it does not appear to be a coordinate system issue. When it did not work in 1.7.1 I installed 1.6.0 and tried the same process, which yielded the same error. Moreover, all other geoprocessing ftools work correctly, so it appears to be an issue with this particular tool.

I have tried installing as an administrator, as I understand that not doing so often causes problems, but that solves nothing.

Whatever the problem is it leads to data corruption, so I consider it a high priority fix.

History

#1 Updated by Paolo Cavallini about 9 years ago

  • Resolution set to duplicate
  • Status changed from Open to Rejected

Duplicate of #3581. Please check carefully before opening a ticket

#2 Updated by Paolo Cavallini about 9 years ago

  • Status changed from Rejected to Closed

#3 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF