Bug report #4324

wrong scale in print composer?

Added by Otto Dassau almost 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:14261

Description

Hi,

using the print composer there are sometimes sudden scale changes within a map window. They appear in raster layers (aerial imagery) and vector shape layer (parcel boundaries). Details are visible in the desktop segment of the program interface and in the resulting generated print. See figures scale_dependent_shift1.png and scale_dependent_shift2.tif.

What could be the reason for it?

Thanks a lot
Otto

scale_dependent_shift1.png (253 KB) Otto Dassau, 2011-09-26 08:18 AM

scale_dependent_shift2.tif (245 KB) Otto Dassau, 2011-09-26 08:18 AM

History

#1 Updated by Bill Williamson almost 9 years ago

Hi Otto,
there was a ticket a while back lodged by Nathan which was consistent with my experience, there was an offset problem when generating pdf maps directly out of composer. We found that printing to an installed pdf printer did not have the problem. I can't find the old ticket and presume there has been some fix, but perhaps the same territory as your problem.
I don't fully understand your example (I see aproblem but the blue arrow points to ? and I don't read German)
Any more detail from your end?

cheers

#2 Updated by Tim Sutton over 8 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#3 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#4 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#5 Updated by Paolo Cavallini about 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#6 Updated by Marco Hugentobler about 8 years ago

  • Status changed from Open to Feedback

Is this still true with latest master?

#7 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#8 Updated by Giovanni Manghi about 7 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

closing for lack of feedback, reopen if necessary.

#9 Updated by Thaddeus - over 6 years ago

  • Status changed from Closed to Reopened

I just came across this erratic behavior of the scale on the Map object of the Composer: after reopening the QGS file, the scale edit box shows a different number (from 240 to 244) and features on the Map object are off the original place.

Also, when manually setting the Map Extents and switching to the Map tab and back to Map Extents, the map corners are rounded off to slightly different numbers, eg, from -7073732.123 to -7073732.118.

Tried this on QGIS 1.8 and 2.0 on Linux and also on MSWin with same results.

My 2 cents:

The ComposerMap entry on the main XML file is saving the map corners in scientific notation rounding off the number to the closets 10m number: it's using only 5 decimal places.

On my test, the CRS is a Modified Mercator (900913) that needs numbers as large as 26706198.518000 meters.

<Composer title="Composer 5" visible="1">
<ComposerMap ... >
<Extent ymin="5.56758e+06" xmin="-7.07373e+06" ymax="5.56764e+06" xmax="-7.07363e+06"/>
...
</ComposerMap>
...
</Composer>

#10 Updated by Jürgen Fischer over 6 years ago

  • Category changed from 33 to Map Composer/Printing

#11 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#12 Updated by Nyall Dawson over 5 years ago

  • Status changed from Reopened to Feedback

Is this still an issue? I can't reproduce it and suspect it's been solved.

#13 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Closed

closing for lack of feedback, reopen if necessary.

Also available in: Atom PDF