Bug report #4290

Attribute table dialog Save Button

Added by James Stott about 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14227

Description

When using the save button on the attribute table dialog it doesnt 'untoggle' and stays depressed. You then have to click it twice the next time you use it and are still not sure it has saved. At the moment I am working around by clicking the Edit button and saving the edits when it prompts me.

Using OSGEO4W Dev version (67dfd2e) on Windows XP.

Save_Button_Problem.jpg (46.3 KB) James Stott, 2011-09-16 01:26 AM

Save_Button_Problem_2.jpg (28.6 KB) James Stott, 2011-09-16 01:28 AM

0001-Fix-checkable-save-button-in-attribute-table.patch Magnifier (736 Bytes) Nathan Woodrow, 2011-09-16 01:44 AM

Associated revisions

Revision 41e70d5a
Added by Nathan Woodrow over 8 years ago

Set save button not checkable - fixes #4290

History

#1 Updated by James Stott about 9 years ago

I forgot it also leaves it depressed when you stop editing the table. I have attached a photo as an example.

#2 Updated by Nathan Woodrow about 9 years ago

Patch attached.

#3 Updated by Tim Sutton about 9 years ago

  • Status changed from Open to Closed

Applied in release branch as 5f7a92e

Thanks!

Tim

#4 Updated by Alister Hood almost 9 years ago

  • Status changed from Closed to Reopened
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

This bug has surfaced again (or is still present) in current trunk.

#5 Updated by Anonymous over 8 years ago

  • % Done changed from 0 to 100
  • Status changed from Reopened to Closed

Also available in: Atom PDF