Bug report #4261

"Merge shapefiles to one" gives bad results

Added by Milena Nowotarska about 8 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alexander Bruy
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System:Windows7 Easy fix?:
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:14205

Description

Merging shapefiles from menu Vector results with one of the layers data shifted.
I am using CRS different than 4326, a local CRS in meters, and perhaps this is the clue.
One of the merged layers is finding itself a place with it's correct coordinates in degrees, which are of course incorrect when the layer should be in meters. The rest of the data indeed finds it's correct placement. Funky, no?
On the fly CRS transformation seems to have no impact.
The shifted layer is not random.
I have checked for 2 sets of data, point and line type.

History

#1 Updated by Giovanni Manghi about 8 years ago

I believe is a known issue.

#2 Updated by Alexander Bruy about 8 years ago

Can you provide sample data? I can't reproduce this with my test dataset (7 polygonal layers)

#3 Updated by Giovanni Manghi almost 8 years ago

  • Status changed from Open to Feedback

Please leave feedback and sample data to allow the dev to make further tests.

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#5 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Subject changed from merge shapefiles to one gives bad results to "Merge shapefiles to one" gives bad results

Hi Milena, can you attach sample data? I believe all the vectors must be in the same CRS, like is required in many other ftools tools.

#6 Updated by Alexander Bruy over 7 years ago

If I understand correctly, all input layers has same local CRS and tool produces wrong result.

Giovanni Manghi wrote:

I believe all the vectors must be in the same CRS, like is required in many other ftools tools.

Right. Currently reprojection during merging operation not implemented (it's possible, of course) and there is no check if all layers have same CRS. So if some input layers have different CRS results may be strange.

#7 Updated by Giovanni Manghi over 7 years ago

Alexander Bruy wrote:

If I understand correctly, all input layers has same local CRS and tool produces wrong result.

Then a sample dataset is fundamental to try replicate the issue.

#8 Updated by Giovanni Manghi over 7 years ago

Right. Currently reprojection during merging operation not implemented (it's possible, of course) and there is no check if all layers have same CRS.

see also #4564

#9 Updated by Alexander Bruy over 7 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme
  • Priority changed from High to Normal

Closed for the lack of feedback

#10 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF