Bug report #4134

trying to connect to a non-spatialite sqlite db makes the mouse pointer into an hourglass

Added by Alister Hood almost 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:14114

Description

Click "Layer->Add spatialite layer->New", select an sqlite database which is not a spatialite database (e.g. ~/.qgis/qgis.db), and click "Connect".
You will get an error message:
Failure exploring tables from: C:/Documents and Settings/alister.hood/.qgis/rasterCatalog.sqlite

no such table: geometry_columns

The mouse cursor will now be changed to an hourglass, and the only way you can fix it seems to be to restart QGIS.

I am using trunk on Win XP if that makes a difference.

History

#1 Updated by Goyo D almost 9 years ago

I am using trunk on Win XP if that makes a difference.

It doesn't. The same on Ubuntu Natty, QGis trunk from qgis repo.

#2 Updated by Alexander Bruy over 8 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Seems this fixed now in trunk. Reopen if necessary

Also available in: Atom PDF