Feature request #4124

Add support for wfs 1.1.0

Added by Lauri Kajan almost 6 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:Web Services clients/WFS
Pull Request or Patch supplied:No Resolution:
Easy fix?:No

Description

I'm in a trouble finding suitable wfs 1.1.0 client.
Currently wfs plugin supports only wfs version 1.0.0.

There aren't many clients that support 1.1.0 so it would be great if QGIS was one of those.


Related issues

Duplicated by QGIS Application - Bug report #3991: WFS 1.1 data is not displayed Closed 06/16/2011

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Target version set to Version 1.7.4

#2 Updated by Anita Graser about 5 years ago

  • Assignee set to Marco Hugentobler
  • Target version changed from Version 1.7.4 to 35

Some work seems to have happened in trunk, but WFS 1.1.0 layers still don't display.

e.g. http://data.wien.gv.at/daten/wfs

#3 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from 35 to Version 1.8.0

#4 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Pirmin Kalberer over 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#6 Updated by Paolo Cavallini almost 3 years ago

  • Status changed from Open to Feedback

Isn't this fixed?

#7 Updated by Anita Graser almost 3 years ago

It seems to work now with above mentioned WFS but I don't know exactly since when ....

#8 Updated by Paolo Cavallini almost 3 years ago

Better close it then?

#9 Updated by Anita Graser almost 3 years ago

Nevermind, I think they enabled WFS 1.0 server-side again, so I don't have a 1.1-only server to test. Do you happen to know any?

#11 Updated by Tilman Brock almost 3 years ago

The request http://gateway.hamburg.de/OGCFassade/DE_HH_WFS_INSPIRE_A1_5_Adressen.aspx?SERVICE=WFS&REQUEST=GetCapabilities&VERSION=1.0.0 (note the version=1.0.0 in the query string) yields a WFS 1.1.0 response. When loaded in QGis, this will fail.

The version upgrade is according to the WFS service version negotiation specification, as seen in https://portal.opengeospatial.org/files/?artifact_id=7176 , Part 6.2.4:

If the client request is for a version lower than any of those known to the server, then the server must send the lowest version it knows.

#12 Updated by Kay Warrie almost 2 years ago

I am having similar issue's with the flemish Mobile Mapping WFS: https://viewer.image-v.be/MM_Opnameposities?service=WFS&request=GetCapabilities&version=1.0.0 --> also return's only 1.1.0 responses even if you request a 1.0.0 one.

#13 Updated by Håvard Tveite about 1 year ago

Support for WFS 1.1 (and 2.0) in QGIS would be great!

A WFS service that only supports versions 1.1 and 2.0:
http://wfs.geonorge.no/skwms1/wfs.skolerogbarnehager

QGIS 2.14.3 says: "Either the WFS server does not support WFS version 1.0.0 or the WFS url is wrong".

#14 Updated by Even Rouault about 1 year ago

  • Status changed from Feedback to Closed
  • Target version changed from Future Release - Nice to have to Version 2.16

Support for WFS 1.1.0 and 2.0.0 has been added in QGIS 2.16. Note: this is still limited to simple feature profiles (so layers such as the one of http://wfs.geonorge.no/skwms1/wfs.skolerogbarnehager will not work)

Also available in: Atom PDF