Bug report #4060

building globe plugin fails: 'GUID' : ambiguous symbol

Added by Alister Hood about 9 years ago. Updated about 9 years ago.

Status:Closed
Priority:Normal
Assignee:Pirmin Kalberer
Category:C++ plugins/Globe
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:14045

Description

After working around #4059, building the globe plugin under MSVC fails like this:

2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(140) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(140) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(149) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(155) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(161) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(166) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(157) : error C2872: 'GUID' : ambiguous symbol
2> could be 'c:\\osgeo4w\\include\\qt4\\qtcore\\quuid.h(58) : _GUID GUID'
2> or 'C:\\OSGeo4W\\include\\osgEarth/Registry(39) : osgEarth::GUID'
2>globe_plugin.cpp

This looks to me like an upstream problem - is that right?
I worked around it by removing the GUID definition in quuid.h

History

#1 Updated by Alister Hood about 9 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

I think this isn't a problem anymore... although maybe it's because I'm building against the OSGeo4W OSG and OSGEarth now.

Also available in: Atom PDF