Bug report #4016

Rotation based on feature attribute in Rule based renderer does not work.

Added by cgsbob - about 9 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:2.10.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:14003

Description

Steps to reproduce this problem:
1) Display point feature property.
2) Select Rule-based renderer.
3) Click on rule "(no filter)" and then click on Refine->Add categories.
4) Select "Column" attribute.
5) Select attribute used to rotate the symbol in Advance->Rotation field.
6) Change the symbol to the arrow symbol.
7) Click on "Classify" and then OK
8) Click OK and you will see that all of the arrows are pointing up rather then in the direction stored in the attribute specified in 5)

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version set to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Nyall Dawson about 5 years ago

  • Affected QGIS version changed from master to 2.10.0
  • Status changed from Open to Closed
  • Resolution set to fixed/implemented
  • Pull Request or Patch supplied set to No

Fixed in 2.10

Also available in: Atom PDF