Bug report #3980

Print composer produces downsampled images regardless of DPI

Added by Aren Cambre over 8 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:13976

Description

The Print Composer declines to produce the best quality image at a given DPI.

Attached are excerpts from two runs of the Print Composer, the only difference that one was run at 300 DPI, and one was run at 600 DPI. Both times I exported to a PNG.

The 600 DPI PNG is 16.3 MB, and the 300 DPI PNG is 7.2 MB.

What should happen: Print Composer produces the best quality image available to a given DPI.

I've also attached an example of what happens on the same area when I do File > Save as Image from within QGIS.

composer_export_300_sample.png (74.4 KB) Aren Cambre, 2011-06-12 01:13 PM

composer_export_600_sample.png (221 KB) Aren Cambre, 2011-06-12 01:13 PM

Save_as_Image.png (333 KB) Aren Cambre, 2011-06-12 01:13 PM

History

#1 Updated by Paolo Cavallini about 8 years ago

  • Category set to 33
  • Pull Request or Patch supplied set to No

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version set to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#6 Updated by Jürgen Fischer over 5 years ago

  • Category changed from 33 to Map Composer/Printing

#7 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

I don't understand this bug... can you please give some more descriptions as to what's wrong with the attached images? They look ok to me...

#8 Updated by Nyall Dawson about 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Closed due to lack of feedback

Also available in: Atom PDF