Bug report #3973

linking pyspatialite fails due to undefined SPL... functions after b74a51e commit

Added by Steven Mizuno over 8 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13970

Description

my build system is Windows 7 / MinGW

Found that link.txt in the pyspatialite build directory does not have libqgis_core.dll.a listed.

This is because python/pyspatialite/CMakeLists.txt references ${EXTRA_LINK_LIBRARIES} which has not been set, and does not list qgis_core at all.

EXTRA_LINK_LIBRARIES is set (and used) by a macro in SIPMacros.cmake which is called several times after the pyspatialite directory is processed by CMake.

I believe that line 34 in python/pyspatialite/CMakeLists.txt should be:

TARGET_LINK_LIBRARIES(pyspatialite qgis_core)

and EXTRA_LINK_LIBRARIES not be used.

This works for my system, but I'm not sure how others may be affected.

Oddly, this worked before the change from SUBDIRS to ADD_DIRECTORY, so there is a different order of processing CMake files.

History

#1 Updated by Alister Hood about 8 years ago

Thanks. I have the same problem with XP / MSVC, and your solution works for me too.

#2 Updated by Tim Sutton almost 8 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#3 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Daniel Vaz about 6 years ago

This still occurs?

#8 Updated by Giovanni Manghi about 6 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Feedback

#9 Updated by Jürgen Fischer about 6 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

fixed in 5e8d129

Also available in: Atom PDF