Bug report #3870

Negative numbers cannot be set as NULL in raster/clipping

Added by alobo - about 9 years ago. Updated almost 9 years ago.

Status:Closed
Priority:Low
Assignee:Giuseppe Sucameli
Category:GDAL Tools
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:13928

Description

At least in raster clipping, I cannot set 32768 as NULL using the
gui, cannot write the "
"
I get
gdalwarp -dstnodata 32768 -q -cutline
/media/Iomega_HDD/FLUXPYR/FlxPyrAOI1/FlxPyrAOI1.shp -dstalpha -of
GTiff /media/Iomega_HDD/FLUXPYR/SRTM/SRTM90v41/srtm36y37_04.tif
/media/Iomega_HDD/FLUXPYR/SRTM/SRTM90v41/srtm90FP.tif
instead of
gdalwarp -dstnodata -32768 -q -cutline
/media/Iomega_HDD/FLUXPYR/FlxPyrAOI1/FlxPyrAOI1.shp -dstalpha -of
GTiff /media/Iomega_HDD/FLUXPYR/SRTM/SRTM90v41/srtm36y37_04.tif
/media/Iomega_HDD/FLUXPYR/SRTM/SRTM90v41/srtm90FP.tif

(cut and paste to the command window was a simple workaround).

Agus

History

#1 Updated by Alister Hood about 9 years ago

This bug also applies to raster>merge and raster>proximity, but not raster>translate, which does accept negative values.

Interestingly, raster>warp has a different entry widget, which accepts text. This could be because somebody wanted to be able to enter none, which is a relatively recent option, and should be enabled for the others also!

#2 Updated by Alister Hood almost 9 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed

Should be fixed in Commit:7093b06793e5999268da7ffa0bf2a974c4730912

#3 Updated by Alister Hood almost 9 years ago

  • Resolution set to fixed

Also available in: Atom PDF