Bug report #3659

Size scale field does not work with symbol levels

Added by Anita Graser over 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13718

Description

When both size scale field and symbol layers are used in a layer style, nothing is drawn.

History

#1 Updated by Anita Graser over 9 years ago

  • Assignee deleted (nobody -)
  • Priority changed from Low to Normal
  • Target version changed from Version 1.7.0 to Version 1.7.1

#2 Updated by Anita Graser over 9 years ago

  • Priority changed from Normal to High
  • Must fix changed from No to Yes

#3 Updated by Tim Sutton almost 9 years ago

  • Target version changed from Version 1.7.1 to Version 1.7.2

#4 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.2 to Version 1.7.3

#5 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.3 to Version 1.7.4

#6 Updated by Giovanni Manghi almost 9 years ago

  • Crashes QGIS or corrupts data set to No
  • Status changed from Open to Feedback
  • Pull Request or Patch supplied set to No
  • Affected QGIS version set to master

Hi Anita, seems to works fine here on both Linux and Windows, 1.7.3 and master. Can you please give it a try again?

#7 Updated by Anita Graser almost 9 years ago

The problem still exists for me in both 1.7.3 and nightly on Win7 (OSGeo4W version).

Reproduced using the Shapefile available here: http://data.wien.gv.at/katalog/baumkataster.html

#8 Updated by Giovanni Manghi almost 9 years ago

Anita Graser wrote:

The problem still exists for me in both 1.7.3 and nightly on Win7 (OSGeo4W version).

Reproduced using the Shapefile available here: http://data.wien.gv.at/katalog/baumkataster.html

I'm not able to replicate the issue myself, can you attach the style or describe the steps? thanks.

#9 Updated by Anita Graser almost 9 years ago

  • Subject changed from Size scale field does not work with symbol layers to Size scale field does not work with symbol levels

I just loaded the shp, left the default point style, checked size scale field "KRONENDURC" and then enabled symbol levels.

#10 Updated by Giovanni Manghi almost 9 years ago

right, sorry I was mislead by "symbol layers" in the description. As a matter of fact if enabling symbol levels the issue is well confirmed.

#11 Updated by Anita Graser almost 9 years ago

Should the status of this issue stay on "Feedback"? There is no way to change it to anything but "Closed".

#12 Updated by Giovanni Manghi almost 9 years ago

  • Status changed from Feedback to Open

#13 Updated by Paolo Cavallini over 8 years ago

  • Status changed from Open to Feedback
  • Target version changed from Version 1.7.4 to Version 1.8.0

#14 Updated by Giovanni Manghi over 8 years ago

  • Operating System deleted (All)
  • Status changed from Feedback to Open
  • Status info deleted (0)

Seems confirmed, so I'll change from feedback to new.

#15 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#16 Updated by Giovanni Manghi almost 8 years ago

  • Priority changed from High to Normal

#17 Updated by Paolo Cavallini over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#18 Updated by Anita Graser over 6 years ago

Symbol Levels work with data-defined size but not with the legacy "size scale field" functionality.

#19 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Feedback

Anita - is this resolved using vmora's work in latest master?

#20 Updated by Anita Graser over 5 years ago

Tried to check but these changes are not in OSGeo4W nightly yet. Will check again tomorrow.

#21 Updated by Anita Graser over 5 years ago

  • Target version changed from Future Release - High Priority to Version 2.10
  • Status changed from Feedback to Closed
  • Resolution set to fixed/implemented

Seems fixed now: Size scale field has been removed from the Advanced button and size scaling can now be achieved using the data-defined override which works well with symbol levels.

Also available in: Atom PDF