Bug report #3613

map units not honored for line offset

Added by Bernhard Ströbl over 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:13672

Description

to reproduce do the following
1) add a polygon layer
2) use new symbology
3) add a "Outline: Simple line" width 5, color green
4) add a "Outline: Simple line" width 1, offset -6, color black
this should result in a thick green line with a black line at the outer edge in any scale
5) change units to "Map unit"
this results in the two lines getting thicker when zooming in but the distance between them stays constant in screen units!

test_style.qml - style file as described in the ticket (4.03 KB) Bernhard Ströbl, 2011-03-14 09:54 AM

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Martin Dobias over 6 years ago

  • Assignee deleted (Martin Dobias)
  • Pull Request or Patch supplied set to No

#5 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Nyall Dawson over 5 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Can't reproduce in current master. Please reopen if still an issue.

#7 Updated by Bernhard Ströbl over 5 years ago

confirmed

Also available in: Atom PDF