Bug report #3607

GDALTools: Inconsistent behaviour on windows standalone in QGIS 1.6

Added by ramon . over 8 years ago. Updated about 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GDAL Tools
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:13666

Description

(Paolo asked me to add my bits to the the ticket, but I can't find it so I'm making this one up. If it does exist, apologies for making more work, but can someone merge them?)

Paolo notes:
In some (but not all) Windows machines (both seven and xp) we are getting
crashes in gdaltools (contour, buildvrt, possibly others) [qgis 1.6,
standalone]. I noticed that there are 2 gdal app folders (16 and 17).
Anyone can confirm the problem?
Any idea of what we can test?

I tested this on two windows machines using standalone 1.6. Both indicate that they are using QGIS 1.6.0 - "Code revision exported", and GDAL/OGR 1.5.4.

One machine is XP (32-bit), the other 7 (64-bit).

For both computers I loaded the same georeferenced jpeg (MGA94,zone 51), and used the GDALTools Contouring option. To make the processing of this file faster I set the contouring to 100 (default 10).

On the winXP 32bit machine it completed with out problems.
On the win7 64bit machine, it displayed "The process crashed sometime after starting successfully" after creating the shape files but before asking what CRS to use.

The created shape files from the two machies are however, identical. (I can add them to the report if helpful)

History

#1 Updated by Alister Hood over 8 years ago

Does this occur with the osgeo nightly builds?
We had the same problem previously, but not now that we are running nightly builds.

#2 Updated by ramon . over 8 years ago

Yes. Seems to work for osgeo both 1.6 and 1.7.

The problem was with the standalone install.

The standalone version is important.

If you need to explain to a windows user how to install QGIS, or uninstall/reinstall, the standalone version makes life simpler. Being the familiar install path, it removes a hurdle to getting someone into GIS.

#3 Updated by Alister Hood over 8 years ago

Seems to work for osgeo both 1.6 and 1.7

Ah, OK.
We had what seemed to be the same problem with the osgeo 1.5 and 1.6, but I guess it could have been a different problem.

#4 Updated by ramon . over 8 years ago

I wouldn't rule that out.

I've only got a small set of computers to compare with (see above), and all but mine are standalone, so I have single sample point to say it works.

Did you or Paolo (if he has had time) see any sort of patterns?

#5 Updated by Alister Hood over 8 years ago

I didn't test on enough machines to see patterns :(

#6 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#7 Updated by Giuseppe Sucameli almost 8 years ago

  • Pull Request or Patch supplied set to No

About the problem with QGis standalone on Win 64bit, see #3476.
Did this problem occur with 32bit OSs as well?

#8 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#9 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#10 Updated by Paolo Cavallini over 6 years ago

  • Assignee changed from Giuseppe Sucameli to anonymous -

#11 Updated by ramon . over 6 years ago

Has anyone seen this one pop up recently?

It's just occurred to me that I've been using gdal's contouring recently and didn't have any problems.

Maybe it's not an issue any more?

#12 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Closed
  • Resolution set to worksforme

#13 Updated by Jürgen Fischer about 5 years ago

  • Assignee deleted (anonymous -)

Also available in: Atom PDF