Bug report #3578

interpolation plugin output without explicit CRS

Added by Giovanni Manghi over 8 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:C++ Plugins
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:13638

Description

Example:

add a layer with certain CRS (see attached file) and then use the interpolation tool.

The output will show correctly overlapped, but it doesn't have associated any explicit CRS, as gdalinfo shows

Driver: AAIGrid/Arc/Info ASCII Grid
Files: /home/gio/Desktop/inter.asc
Size is 300, 300
Coordinate System is @'
Origin = (1646340.000000000000000,4834290.000000000000000)
Pixel Size = (157.166670000000011,-103.099999999999994)
Corner Coordinates:
Upper Left  ( 1646340.000, 4834290.000) 
Lower Left  ( 1646340.000, 4803360.000) 
Upper Right ( 1693490.001, 4834290.000) 
Lower Right ( 1693490.001, 4803360.000) 
Center      ( 1669915.001, 4818825.000) 
Band 1 Block=300x1 Type=Float32, [[ColorInterp]]=Undefined
  [[NoData]] Value=-9999

pontos_shp.zip (209 KB) Giovanni Manghi, 2011-03-09 03:32 AM

create-prj.patch Magnifier (1.65 KB) Alexander Bruy, 2011-12-15 08:14 AM

Associated revisions

Revision 34421c89
Added by Alexander Bruy over 5 years ago

assign CRS to interpolation output (fix #3578)

History

#1 Updated by Paolo Cavallini over 8 years ago

  • Tracker changed from Bug report to 4
  • Start date set to 2011-07-25
  • Pull Request or Patch supplied set to No

#2 Updated by Alexander Bruy almost 8 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • File create-prj.patchMagnifier added

Here is quick fix for this. I know it's not optimal

#3 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Giovanni Manghi over 7 years ago

  • Affected QGIS version set to master
  • Tracker changed from 4 to Bug report
  • Crashes QGIS or corrupts data set to No

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Giovanni Manghi almost 7 years ago

  • Priority changed from Low to High
  • Operating System deleted (All)
  • Status info deleted (0)

Alexander Bruy wrote:

Here is quick fix for this. I know it's not optimal

This issue still true on master, Alexander, was this patch ever committed?

#8 Updated by Alexander Bruy almost 7 years ago

Giovanni Manghi wrote:

This issue still true on master, Alexander, was this patch ever committed?

AFAIK, it is not applied. I don't commit it and leave for review because proposed solution is not ideal, maybe there is a better way to fix this.

#9 Updated by Giovanni Manghi almost 7 years ago

  • Priority changed from High to Normal

#10 Updated by Daniel Vaz over 6 years ago

I think that supplied patch do the job in the right way. :-)

#11 Updated by Giovanni Manghi over 6 years ago

Daniel Vaz wrote:

I think that supplied patch do the job in the right way. :-)

If the patch is not submitted on github then is unlikely that will be reviewed and eventually committed.

#12 Updated by Paolo Cavallini almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - High Priority

#14 Updated by Alexander Bruy over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF