Bug report #3538

Save layer as "GeoJSON" loosed projection information

Added by springmeyer - almost 7 years ago. Updated about 2 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No

Description

If you export vector data from QGIS using Layer > Save layer as... and choose GeoJSON as a format the data is exported without a "crs" property.

In my case my data (originally a shapefile) is in Google Mercator, and I chose "Original CRS". I also tested with data in WGS 84 and tried setting the output CRS to something custom, BC Albers, but still no projection definition was written. I confirmed this by looking through the outputted geojson with a text editor and also by calling ogrinfo -so -al <json> and seeing that ogr wrongly reports WGS84 (as assume this is the case because this is the default according to the GeoJSON spec).

I am running QGIS 1.6 on OS X

History

#1 Updated by Giovanni Manghi almost 6 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 5 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini over 5 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer over 3 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Médéric RIBREUX about 2 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • % Done changed from 0 to 100
  • Resolution set to fixed/implemented

Hello, bug triage...

this is not the case anymore in QGIS 2.13:

"crs": { "type": "name", "properties": { "name": "urn:ogc:def:crs:EPSG::23030" } },

I am closing this bug.

Also available in: Atom PDF