Feature request #3393

Help Contents not about using QGIS

Added by Alex Mandel over 6 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Low
Assignee:Otto Dassau
Category:Documentation and Help
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No

Description

Opening the help contents doesn't provide much in the way of useful information for a normal user. On my Ubuntu system it's a page about compiling QGIS, on my Trunk build it's the changelog which is also accessible in the About dialog. Can someone check this on recent builds of Mac/Windows?

My suggestion would be to include the latest user manual in html form generated from the latex source in a Qt Web View. Or to include the PDF version in the distribution and open it on request. New users really need the basic what are each of these buttons and how do I install/use plugins in the built in help.

History

#1 Updated by mlennert - over 6 years ago

Coming over from #3718 which was closed as duplicate of this one: I think it would already be a great start to have the manual in browsable form (and not only as PDF download) on the QGIS website.

Moritz

#2 Updated by Giovanni Manghi almost 6 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 1.7.4 to Version 2.0.0

#4 Updated by Pirmin Kalberer almost 5 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#5 Updated by Alexander Bruy over 2 years ago

  • Pull Request or Patch supplied set to No

Now Help Contents points to the documentation site. But seems it used current version number, not latest stable one, so for master branch it gives 404 as manual is not here.

#6 Updated by Médéric RIBREUX almost 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Hello, bug triage...

as of today, QGIS 2.13 master points to testing manual and QGIS 2.12 Lyon (non LTR version) points to 2.8 manual (stable).

Everything has been fixed on QGIS doc website to redirect master and 2.12 to testing and 2.8.

I am closing this feature request.

Also available in: Atom PDF