Bug report #3346

Bug: composer legend - symbols and labels are not vertically aligned

Added by Alister Hood almost 9 years ago. Updated over 7 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:13406

Description

In a composer legend the symbols and the labels should be vertically aligned, so that their centres are at the same level.

Currently they are not necessarily aligned . e.g. in the attached screenshot the labels are slightly lower than the symbols.

I have seen screenshots where they are aligned, so I'm guessing it depends on the spacing (or perhaps font) settings.

I suspect this is really a duplicate of #168, but I'm opening a new ticket since that one is so old (sorry if I should have reopened it instead).

legend.PNG - screensot of composer legend with slightly misaligned labels (8.24 KB) Alister Hood, 2010-12-16 02:52 PM

History

#1 Updated by Marco Hugentobler over 8 years ago

  • Status changed from Open to Resolved
  • Assignee deleted (nobody -)

This should be fixed in commit a083c5e7332bf975852e

#2 Updated by Alister Hood about 8 years ago

Yes, looks like it. Thanks.

#3 Updated by Mathieu Pellerin - nIRV about 8 years ago

Marco, I'm not a 100% sure but I think this commit might have caused a visual regression for market symbols in legend, described in issue 4043 (#4043).

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#6 Updated by Giovanni Manghi over 7 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Resolved to Closed
  • Resolution set to fixed

Also available in: Atom PDF