Bug report #3333

GdalTools: strange responsivenes of multiple files selector

Added by Giuseppe Sucameli over 9 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GDAL Tools
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:13393

Description

In Merge tool, but this might be also the case for other tools.

Compared to regular QGIS raster selector the selector in Merge is somewhat strange while selecting multiple rasters while dragging mouse.

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Pull Request or Patch supplied set to No
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

See also #3869

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#4 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Paolo Cavallini over 7 years ago

  • Assignee changed from Giuseppe Sucameli to anonymous -

#6 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Jürgen Fischer about 6 years ago

  • Assignee deleted (anonymous -)

#8 Updated by Médéric RIBREUX over 4 years ago

  • Status changed from Open to Feedback

Hello, bug triage...

I have seen some differences between the QFileDialog of the main QGIS Raster selector and the GDALTools selectors but they have the same behaviour in selection:

- on QGIS Raster selector, you can take files and move them from a directory to another. Same thing with GDALTools.
- on QGIS Raster selector, you can add/remove files by pressing Ctrl+click. Same thing with GDALTools.
- on QGIS Raster selector, you can select multiple files and drag them where you want. Same thing with GDALTools.

The only difference is that the QFileDialog in GDALTools doesn't look like a native file selector on MS-Windows (not the same shortcuts on the left). On Debian, they are exactly the same.

What do you meant by "strange responsivenes of multiple files selector" ?

#9 Updated by Médéric RIBREUX over 4 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Hello, bug triage...

I am closing this bug report for lack of feedback and because I can't find any "strange responsivenes" in Merge file dialog.
Feel free to reopen it with more explanations...

Also available in: Atom PDF