Feature request #3209

Set "Skip attribute creation" as a default setting when user chooses "Microstation DGN" format for export

Added by Paolo Cavallini over 6 years ago. Updated 12 days ago.

Status:Closed
Priority:Low
Assignee:-
Category:Vectors
Pull Request or Patch supplied:No Resolution:fixed/implemented
Easy fix?:No

Description

New description:

"Skip attribute creation" as a default setting when user chooses "Microstation DGN" format for export

Old description:

Converting (right click->Save as...) a shp in gpx results in an error:

creation of field DATA_INI failed (OGR error: Field of name 'DATA_INI' is not
supported in GPX schema. Use GPX_USE_EXTENSIONS creation option to allow use of the
<extensions> element.)

This crashes my machine.

Similar stuff while saving to DGN files.

Associated revisions

Revision 7634b0b7
Added by Jürgen Fischer 12 days ago

vector file writer fixes:
  • don't apply un-overridden default options
  • DGN: don't export attributes and fix layername to "elements"

Revision 9a6235db
Added by Jürgen Fischer 12 days ago

vector file writer fixes:
  • don't apply un-overridden default options
  • DGN: don't export attributes and fix layername to "elements"

(cherry picked from commit 7634b0b759bc0cedba28f9e9199d6a81a498ec5a)

History

#1 Updated by Luca Casagrande over 6 years ago

To avoid errors when converting to GPX, the flag -dsco GPX_USE_EXTENSIONS=YES should be enabled by default.
It doesn't bring any data corruption, it just add extra fields inside the<extensions> tag.

#2 Updated by Jürgen Fischer over 6 years ago

That's what the "data source" field in "OGR creation options" is for and getting to GPX_USE_EXTENSIONS takes three clicks and a little bit of scrolling starting with the "help" button.

I suppose you didn't mean tht your whole machine crashes after the error message.

#3 Updated by Giovanni Manghi over 5 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#4 Updated by Giovanni Manghi about 5 years ago

  • Target version changed from Version 1.7.4 to Version 2.0.0

#5 Updated by Simone Bianchi about 5 years ago

I am wondering if the following problem is related.

I'm trying to download data from a Garmin 60csx, but it reports everytime The layer C:/Users/simblanco/Documents/GIS/test.gpx?type=waypoint is not a valid layer and can not be added to the map. The problem is that the file is not saved on the harddisk. I don't know if it is possible to enable GPX_USE_EXTENSIONS for this procedure.

(The problem I guess is not in the GPS usb connection because I edited the settings and the GPS is indeed beeping when I enter the command)

#6 Updated by Pirmin Kalberer over 4 years ago

  • Target version changed from Version 2.0.0 to Future Release - Nice to have

#7 Updated by Médéric RIBREUX over 1 year ago

  • Pull Request or Patch supplied set to No
  • % Done changed from 0 to 50
  • Assignee deleted (nobody -)
  • Status changed from Open to Feedback

Hello, bug triage...

for GPX export, there is now (QGIS 2.13 master) no problem, the GPX_USE_EXTENSIONS is set to YES by default. Half done !
For DGN, there is a problem for the default settings: DGN seems to not accept attributes .

We need to set "Skip attribute creation" as a default setting when user chooses "Microstation DGN" format for export.

#8 Updated by Médéric RIBREUX over 1 year ago

  • Status changed from Feedback to Open

#9 Updated by Giovanni Manghi over 1 year ago

  • Status info deleted (1)
  • Subject changed from saving to GPX or DGN fails to Set "Skip attribute creation" as a default setting when user chooses "Microstation DGN" format for export
  • Category changed from Data Provider to Vectors
  • Operating System deleted (All)

#10 Updated by Giovanni Manghi about 2 months ago

  • Easy fix? set to No

#11 Updated by Jürgen Fischer 12 days ago

  • Description updated (diff)

Fixed in 9a6235dba and 7634b0b75

#12 Updated by Jürgen Fischer 12 days ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Also available in: Atom PDF