Bug report #3146

Erase button always disabled

Added by aperi2007 - about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:13206

Description

In the property layer, in the attribute window the
icon (button) remove column is always disabled.
So is impossible to remove a column from a shapefile.

History

#1 Updated by Jürgen Fischer about 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

um, this still a duplicate of #1446 - just like #3070.

#2 Updated by Alessandro Pasotti about 10 years ago

This bug is set as duplicate of #1446 (which appears to be fixed 21 months ago), the bug is still present in 1.5.0 tethis, please consider reopening.

#3 Updated by Giovanni Manghi about 10 years ago

the problem IS NOT qgis, is OGR. The patch to allow OGR delete shapes colums has already been filed a long ago, but never committed. Please see gdal/ogr bug tracker.

Also available in: Atom PDF