Bug report #3070

erase column in attribute table don't work

Added by aperi2007 - about 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Vectors
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:13130

Description

Using shapefile.
Open attribute tableand setting to edit on.
The button erase table is still disabled.
Is not possible to erase effectively a column.

History

#1 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Not a QGIS problem, OGR does no allow to delete columns in shapes. There is a patch submitted in the ogr trac since a long ago, but it wasn't yet committed.

Workaround: use the table manager plugin

#2 Updated by Jürgen Fischer about 10 years ago

duplicate of #1446

Also available in: Atom PDF