Bug report #3096

Silent install is not possible when used to upgrade QGIS

Added by asgerpetersen - almost 10 years ago. Updated about 2 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:13156

Description

When running the windows standalone installer with the silent switch (/S) on a system with an earlier version of QGIS, the installer is not silent as it shows a dialog box to confirm the upgrade. This is especially a problem with the installer is running as part of a startup script, because then the dialog is hidden. This prohibits central administration of QGIS in a Windows environment.

Command used: QGIS-OSGeo4W-1.5.0-14109-Setup.exe /S

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer about 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Giovanni Manghi over 3 years ago

  • Pull Request or Patch supplied set to No
  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Jürgen Fischer about 2 years ago

  • Resolution set to worksforme
  • Description updated (diff)
  • Status changed from Open to Closed

Also available in: Atom PDF