Bug report #2857

Automatically change tools and right menu issue

Added by dr - about 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:12917

Description

1. Open raster layer;

2. Choose Measure Line or Measure Area tool and get an error message:

This map is defined with a geographic coordinate system (latitude/longitude) but the map extents suggests that it is actually a projected coordinate system (e.g., Mercator). If so, the results from line or area measurements will be incorrect.

3. Press Ok;

4. Choose Pan Map tool and click right button in the View. Pan Map tool automatically changes to Measure Line or Measure Area tool (the first bug) and throws up error message.

5. Click Ok and get right menu (the second bug).

History

#1 Updated by dr - about 9 years ago

Upd.

4. Choose Pan Map or Zoom In or Zoom Out or maybe any another tool...

#2 Updated by Borys Jurgiel over 8 years ago

The first "bug" is a feature - right click on the map canvas switches to the previous tool.

The second one I don't understand. There's no map canvas context menu...

#3 Updated by sunilkcube - over 8 years ago

  • Status changed from Open to In Progress

#4 Updated by Giuseppe Sucameli over 8 years ago

As borysiasty said the first is a feature (right click on canvas switches to the previous non-zoom/non-pan tool).

About the second bug, I cannot confirm here on Ubuntu. It's set as Win platforms bug.

#5 Updated by Jürgen Fischer over 8 years ago

What raster did you open and what coordinate system did it have (or which one did QGIS detect)?

I guess it didn't have any usable information about it's coordinate system and therefore defaulted to WGS84, but did have coordinates outside -90°-90°/-180°-180°.

If so, there is no bug at all. Both restoring the last non-zoom tool on right click and complaining about invalid coordinates are features (ie. intended behaviour).

#6 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#7 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master

#8 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#9 Updated by Nathan Woodrow over 5 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from In Progress to Closed
  • Assignee deleted (sunilkcube -)
  • Resolution set to invalid

These are both features not bugs.

Also available in: Atom PDF