Bug report #2781

Relative paths to SvgMarker doesn't work in new symbology

Added by dr - over 9 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:12841

Description

If open *.qgs file and manually set relative path to svg marker, e.g.

<prop k="name" v="./atm.svg" />

save *.qgs and open it - all works fine. But if open *.qgs and chose File -> Save Project, then relative paths changes to absolute paths. Project Properties -> Save paths -> relative doesn't work for svg markers paths.

2781 - Using QgsProject::instance()->writePath in symbolPathToName (912 Bytes) René-Luc ReLuc, 2012-10-01 09:19 AM

History

#1 Updated by Martin Dobias over 9 years ago

This seems to be the case also with old symbology - the relative paths are loaded correctly, but saved with absolute paths.

#2 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#4 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by René-Luc ReLuc almost 7 years ago

#6 Updated by Giovanni Manghi almost 7 years ago

  • Assignee deleted (Martin Dobias)
  • Pull Request or Patch supplied set to Yes
  • Status info deleted (0)
  • Operating System deleted (All)

#7 Updated by Homme Zwaagstra almost 7 years ago

Martin Dobias wrote:

This seems to be the case also with old symbology - the relative paths are loaded correctly, but saved with absolute paths.

#1665 is claiming to have solved this...

#8 Updated by René-Luc ReLuc almost 7 years ago

What about my patch ? Someone to review it ?

#9 Updated by Marco Hugentobler almost 7 years ago

  • Assignee set to Marco Hugentobler

#10 Updated by Martin Dobias almost 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF