Bug report #1665

Use of relative paths for SVG symbols in QGIS project file

Added by Andreas Neumann over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:11725

Description

Currently, QGIS uses absolute paths in project files. This is a problem when moving projects around, especially when using it in multiple operating systems.

QGIS should use relative paths (relative to the qgis/share/svg directory), which is different on every platform.

as an example:
svg:/usr/local/share/qgis/svg/abwasser/Baujahrwechsel.svg
should be changed to
svg:abwasser/Baujahrwechsel.svg

QGIS should also automagically replace forward with backward slashes when it opens on the windows platform. It would be useful to use the forward slashes notation in the project file for all platforms to be consistent. This is also the convention with URLs.

Thanks for looking at this problem.

History

#1 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1211

Also available in: Atom PDF