Bug report #2745

Attempt to create new spatiaLite layer fails

Added by rcline - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:William Kyngesburye
Category:GUI
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12805

Description

When the New SpatiaLite Layer menu item is selected, the dialog to create the layer does not appear. I am using development builds from the KyngChaos site. This works in build r13289, but does not work in the newer r13385 and r13519 builds. Using OS X 10.6.3.

History

#1 Updated by Jürgen Fischer over 11 years ago

not reproducable in 53a60d25 (SVN r13567) on Linux and Windows.

#2 Updated by rcline - over 11 years ago

Running QGIS from the terminal, I get the following warning:
Warning: Object::connect: No such slot QgisApp::newSpatialiteLayer()

There were changes made to add new SpatiaLite layer in dc39570f (SVN r13295). Is it possible this change broke adding a SpatiaLite layer in OS X as it worked in 6b657088 (SVN r13290).

#3 Updated by William Kyngesburye over 11 years ago

  • Status changed from Open to In Progress

I messed up a sqlite setting in the Xcode project, so qgsspatialitesourceselect.cpp|h were not compiled.

working on it...

#4 Updated by William Kyngesburye over 11 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

OK, turns out you had the right track - while newSpatialiteLayer() should be conditionalized in qgisapp.cpp, it should not be so in qgisapp.h. newSpatialiteLayer() must exist (defined in qgisapp.h), it's just an empty function if spatialite is not enabled.

fixed in 519c04ba (SVN r13568). I'll package up a new Mac dev build later.

Also available in: Atom PDF