Bug report #2713

"Leaking" strokes using non-continuos outline

Added by Sandro Santilli about 10 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:12773

Description

When changing the outline option of a polygon layer to non-linear
(dashed, dotted and so on) the resulting rendering shows more lines
than it should. Seems like a visual leak.

I attach a screenshot showing the correct rendering (the plain one)
and the dashed (bogus) one.

Resizing the viewport or panning doesn't fix the rendering problem.

This is trunk r13473, on Ubuntu 8.10 with its own packaged qt libs.

pacific.png - The correct rendering (7.43 KB) Sandro Santilli, 2010-05-13 01:32 PM

bogus.png - The bogus rendering (27.4 KB) Sandro Santilli, 2010-05-13 01:33 PM

History

#1 Updated by gjm - almost 10 years ago

The recent assignment to jef was unintended. There seems to be no way to put it back to 'nobody' :(

#2 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini about 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#4 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#5 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#6 Updated by Nyall Dawson almost 5 years ago

  • Status changed from Open to Feedback
  • Assignee deleted (zxglive2006 -)
  • Pull Request or Patch supplied set to No

Is this still an issue with current versions?

#7 Updated by Sandro Santilli almost 5 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Can't reproduce, this ticket does not include enough information to try better. My fault. Will re-open or file a new one shall it happen again.

Also available in: Atom PDF