Bug report #2637

Composer default extent on existing map wrong

Added by John Tull over 9 years ago. Updated over 5 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:12697

Description

The map composer, on OS X at least, always displays an existing map in a shrunken view rather than at the fullest possible extent for the window. I've attached a picture that shows this.

composer_default.jpg - Composer default view on OS X (97.3 KB) John Tull, 2010-04-08 10:32 AM

History

#1 Updated by Marco Hugentobler over 9 years ago

Is this still true? I tried the print composer on a macbook with William's nightly build (856347c4 (SVN r13598)). The default size there seems ok to me (appr. left half of the screen is preview and the right half is widget).

#2 Updated by John Tull about 9 years ago

Sorry for the delay. For my cmake builds, it is still true. I do not know what might be different that would cause this. I tried making my own xcode build, but it is failing to build with current trunk for me.

#3 Updated by John Tull over 8 years ago

This is still a problem on OS X, but only when a project file (qgs) is reopened. I.e., if you have an active project and composer item, opening, closing, and opening the map composer item is fine, but if you quit QGIS or reopen that project, then the composer item is displayed oddly as shown in the attached image.

#4 Updated by Giovanni Manghi almost 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#5 Updated by Paolo Cavallini over 7 years ago

  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0

#6 Updated by Paolo Cavallini about 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#7 Updated by Jürgen Fischer over 5 years ago

  • Category changed from 33 to Map Composer/Printing

#8 Updated by Nyall Dawson over 5 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed
  • Pull Request or Patch supplied set to No

Is this still an issue? I can't reproduce it under current master on osx. There's been changes to the composer code which may have fixed this too. I'll close this for now, please reopen if you still see issues.

Also available in: Atom PDF