Bug report #2472

some menus have small height in unpopped state with Qt 4.6

Added by William Kyngesburye over 10 years ago. Updated over 6 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:12532

Description

On OSX, with Qt 4.6, both Carbon 32bit and Cocoa 64bit, some menus have a small height, just to the top/bottom pixel of the text label in the menu. Yet popped, menu selection items have a normal height. It's more pronounced in Qt Cocoa. See attached images.

qgis-popup_menu_small_height.png - short menu height (10.3 KB) William Kyngesburye, 2010-02-25 03:15 PM

qgis-popup_menu_normal_height.png - normal menu height (9.38 KB) William Kyngesburye, 2010-02-25 03:15 PM

History

#1 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini over 8 years ago

  • Crashes QGIS or corrupts data set to No
  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master

#3 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by William Kyngesburye over 6 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • Resolution set to worksforme

It looks like this was incidentally fixed somewhere along the way, either in QGIS or Qt.

Also available in: Atom PDF