Bug report #2377

Symbology legend classification items can get out of sync with classification field

Added by springmeyer - about 10 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:12437

Description

Using current symbology (not sym-ng) and a postgis dataset (openstreetmap) it is possible to:

1) choose unique value symbology

2) choose a classification field of text and classify features

3) then still within the symbology interface change the classification field to a int4 type

4) then leave the symbology interface without again hitting 'classify'

I know this is a bit of a fringe thing, and I'm not sure out the right solution, but I noticed this because somehow I managed to do this and it breaks Quantumnik (and I assume other plugins that query the classification field type and value), because QGIS reports int4 (Qvariant.Int) type but returns text-based feature values.

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#2 Updated by Paolo Cavallini almost 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0
  • Affected QGIS version set to master
  • Crashes QGIS or corrupts data set to No

#3 Updated by Paolo Cavallini over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Jürgen Fischer almost 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#5 Updated by Giovanni Manghi over 4 years ago

  • Pull Request or Patch supplied set to No
  • Status changed from Open to Closed
  • Assignee deleted (nobody -)
  • Operating System deleted (All)
  • Status info deleted (0)
  • Resolution set to wontfix

Also available in: Atom PDF