Bug report #2202

UI's glitches when using the FR localization

Added by Jean-Roc Morreale almost 11 years ago. Updated over 9 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Mandriva Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12262

Description

Hello, I've 2 situations where the fact of using fr_Fr cause problems in the interface. They're not blocking, just making the interface harder to read.

1. There is no space between the label of the box and the number even when the text has a similar length than the en_US version (see screenshot 'boxspace.png')

2. The new vertical tabs list is too small to handle the translated title (see screenshot 'listspace.png'). This one can also be seen using 'de' as the locale.

I can't say if this a platform specific problem as i do not have trunk's build for Windows

boxspace.png - it shows the lack of space between labels and numbers (112 KB) Jean-Roc Morreale, 2009-12-06 10:01 AM

listspace.png - it shows the horizontal space limitation in the global parameters' list (62.6 KB) Jean-Roc Morreale, 2009-12-06 10:03 AM

Associated revisions

Revision 8006e3c2
Added by Jürgen Fischer almost 11 years ago

fix #2202

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 944c4572
Added by Jürgen Fischer almost 11 years ago

fix #2202

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jean-Roc Morreale almost 11 years ago

#3905 is solved as extra blank space has been added in the the fr.ts file. #3906 remains the same.

#2 Updated by Jean-Roc Morreale over 10 years ago

The issue is still valid on WinXP/GNOME/KDE, I've to change the default font size of Qt to have the whole text inside the column but even then the cions are not aligned.

#3 Updated by Paolo Cavallini over 9 years ago

Still true for trunk?

#4 Updated by Jean-Roc Morreale over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

tab are now handled horizontally so this problem doesn't exist anymore, I'm closing this ticket

Also available in: Atom PDF