Feature request #3906

Save/restore default symbology

Added by Steve Halasz - over 13 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:Project Loading/Saving
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:13930

Description

I would love to have an option in the symbology preferences to "save as default". This would save the symbology info in a .qgl file for instance. Each provider would implement it differently. When adding the layer again later it would apply the default symbology automatically if it is found.

History

#1 Updated by Gary Sherman over 13 years ago

This is an important feature to have in place by the 1.0 release.

#2 Updated by Redmine Admin about 13 years ago

this seems the same as #169. Better merge the two?

#3 Updated by shalasz - about 13 years ago

#169 is a duplicate of this. Paolo says:

It would be very useful to have the possibility of saving layer properties even independently of projects; therefore different users or different projects could share uniform layer colours, transparency etc. GRASS implements a similar mechanism with RGB column in the database (which would be good to be able to reuse in QGIS). This, couples with the possibility of assigning properties to a bunch of layers (like a "catalog") would allow much smoother work.

#4 Updated by Tim Sutton almost 12 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Ticket #840 which I opened recently also duplicates this. I know this is the first report for this, but Im closing this ticket and managing it further from #840.

#5 Updated by Anonymous about 10 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF